S1 pod (paid plan) cannot go over 9M vectors of size 32

Hello pinecone,

I tried a paid plan with s1 pod and 32 vector’s dimensions, I see on the doc that with 512 it can go maximum to 8M vectors, which is a lot, but I couldn’t go over 9M with size 32, no metadata.
according to the doc, it should technically go up to 120M. For info I tried with a single namespace then with a 100 namespaces to see if that was the problem.

Thanks for reaching out. You’ll want to increase the size of the pod from x1 to a larger size like x2 (double the storage). You can do this from the console or the API. If you need larger than x8, you can use collections to create and index with more pods.

@thomasduduFR, just to be clear, the sizing guidelines are not a hard and fast rule; pods don’t linearly scale like that. They’re just guidelines, and we always recommend using your own data to test to make sure of what you can fit before moving to production.

There’s some administrative overhead on vectors that consumes a fixed amount of storage, but this generally affects low-dimension data more than high-dimension data. So, while the guidelines are accurate for 512, 768, or 1536 dimensions, 32 or 64 dimensions could be very different. That’s why you’re seeing the difference in storage outcomes that you are.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.