Request failed. You've reach the max pod-based indexes

I need help regarding this matter, I’ve deleted the index just to make sure as well I have a pdf data that is over a ~5000 page and i’ve split the document via haystack using document splitter indexing.add_component("splitter", DocumentSplitter(split_by="page", split_length=1)) I’ve also tried
split_by="sentence" with split_lenth=5

I’ve also tried using a 20 page pdf with little to none texts

Hi @notme_MA, and welcome to the Pinecone forums! Thanks for your question.

Could you please share all of your relevant code so that we can better assist you in debugging the issue?

It’s difficult to tell what might be going wrong from your description.

General tips and advice based on what I can surmise might be happening:

  1. Can you follow one of haystacks examples or notebooks that splits a PDF and start out with a smaller sample PDF to sanity check you’re getting reasonable output?
  2. If you then modify that test code to use your PDF, what happens? Can you share the output or error messages you’re seeing as well?
  3. Check if haystack has any hard limits on PDF size

Hope this helps and looking forward to your reply.

Best,
Zack