Query does not work anymore

I had issues in the last 2 days with whole pinecone-client library. However, today I cannot even query the index.
I explain better:

  • I worked with the new index until today and I could query (however I had other issues)
  • Suddenly it stopped working and I got an error when I was querying (now I lost the traceback).
  • I downgraded the version to the 2.2.4 and I still have problems when I query (long time to retrieve and now the score is just disappeared - only 0 for all the items.

Anyone knows what’s going on?

Hi @andesogus, sorry you’re running into trouble. I know you said you lost the stacktrace, but could you run your script again to capture it? Knowing what kinds of errors you’re running into is important to knowing what the right next steps are.

We recommend staying on version 3.0, especially if you’re using serverless. There are some important improvements in it.

Hi @Cory_Pinecone !

Now that I have upgraded again with the last version I can query again. Unfortunately it’s far slower than before (I mean, for querying now it takes also 5 seconds vs the usual <0.5 sec) and I cant see anymore the score associated.
I do not have serverless, I’m still on the free tier which worked super fine until the last week.

Could it be related to the new version? Any solution for the score and the performance?


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.