Pinecone Upsert finding strings in my vectors

I just started using Pinecone and am on the free starter tier. I’m trying to create an index and upsert vector representation of images for use in a visual search engine. My vectors are generated from fine-tuned resnet50 (2048 dimensions) and I’m getting a value-type error where strings are being detected in the vector value lists. I ended up creating a dummy vector and I’m still getting the same error.

Create a dummy vector with 2048 dimensions

dummy_vector = [1.0]*2048

Confirm the type of dummy vector and its elements

print(type(dummy_vector)) # Should output <class ‘list’>
print(all(isinstance(x, float) for x in dummy_vector)) # Should output True

Create a dictionary to hold the dummy vector

dummy_dict = {“dummy_item”: dummy_vector}

Insert the dummy vector into the index

try:
index.upsert(vectors=dummy_dict)
except ValueError as e:
print(“An error occurred during upsert operation:”, str(e))

<class ‘list’>
True
An error occurred during upsert operation: Invalid vector value passed: cannot interpret type <class ‘str’>

I’m new to computer Vvsion and vector databases so maybe it’s an extremely simple thing I’m missing or doing wrong here.

Ok, so I’ve realized I needed to convert into a tuple. Problem solved