NodeJs installs module not found issues - inconsistent package names help

I have tried a few examples of tenplates, asked GPT on the pinecone site and after hours or searching still unable to create a simple connect script in NodeJs. This worked fine with python client and modules without issue. Is it safe to assume NodeJs connection to Pinecone is still not stable ? I have tried all variants of package installs to get it to work with a JS script and no luck. What is up with the varying package names like

npm install @pinecone-database/client

yet referring to these after install says Cannot find module ‘@pinecone-database/client’
which leads me to the message about being beta ? is it working or not working with npm module availability?

Hi Charles,

Thanks for opening this issue, and sorry to hear you’re encountering issues.

  1. Here’s an example you can use
  2. The module name is definitely @pinecone-database/pinecone
  3. Could you help us understand where you got the @pinecone-database/client piece? Was that from ChatGPT or just a guess? We want to ensure it wasn’t found in our docs, for example.
  4. I can share that we are launching a totally revamped TypeScript client - we are currently aiming to release it next week
  5. If it’s helpful, here’s a currently in-progress PR showing the updated README

Hope that helps - let me know.