I got this error

ApiException: (400)
Reason: Bad Request
HTTP response headers: HTTPHeaderDict({‘content-type’: ‘application/json’, ‘Content-Length’: ‘115’, ‘date’: ‘Tue, 21 Nov 2023 13:21:34 GMT’, ‘x-envoy-upstream-service-time’: ‘16’, ‘server’: ‘envoy’, ‘Via’: ‘1.1 google’, ‘Alt-Svc’: ‘h3=“:443”; ma=2592000,h3-29=“:443”; ma=2592000’})
HTTP response body: {“code”:3,“message”:“Metadata size is 41206 bytes, which exceeds the limit of 40960 bytes per vector”,“details”:}

Hi @aitest242

Your problem lies in the amount of data you are adding via metadata

Reduce the amount of data and you should be able to upsert with no problem :slight_smile:

Hope this helps


Thanks for reply.

i just want to know is there any other way to increase there metadata limit of per vector by purchasing any subscription or any other option for it?

Storage space in vector DBs is much more expensive compared to alternatives.

If you’re just storing data that’s associated with your vectors, so that you can retrieve it when a vector search matches, then I would instead consider storing that data in a separate DB and just storing a reference (e.g. unique ID) in Pinecone that points to the clear-text content in the other DB.

To minimize costs and maximize performance, you should limit what you store in Pinecone to:

  • Vectors
  • Metadata that enables filtering of semantic search results
  • Small quantities of associative metadata
    • Small text data, if needed for convenience
    • Reference IDs pointing to larger quantities of text in another system

Got it. best explanation Thank you :innocent:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.