Can't create PC index using "canopy start"

Hi! I’m new to Pinecone. I decided to start with Canopy from GitHub because it seemed simple.
I have correctly setup Pinecone_API_key and OpenAI_API_key. Then I tried to create an index by using ‘canopy new’.
When I do that, the CLI was first complaining about the AWS server being US_west_1. Maybe that’s because I’m in Brasil, maybe not.
I’ve read a lot. I tried the AI chatbot. There’s little information on the config file or index creation using the CLI for Canopy.
Then I read a community topic answered by @ZacharyProser – I created the index inside Pinecone, and it’s there.
The index is called cdc-index
When I try to input the CLI

canopy upsert c:\path\to\my_file.jsonl

… I get an error saying

The index canopy–cdc-index does not exist or was deleted. Please create it by calling knowledge_base.create_canopy_index() or running the canopy new command


But, as I said, I can’t run “canopy new” because it will give me another AWS “US_West_1” error.

How do I get out of this?
Many thanks!

Hi @wasemag and welcome to the Pinecone community forums!

Thank you for your question and sorry to hear you’re running into this issue.

First, Canopy doesn’t support creating the index separately using Pinecone API \ website - you have to run canopy new from the start - that may be part of your issue.

If you are having problems with canopy new please open an issue against the repo and one of the team members who maintains it will help you out.

When you do that - could you also share your full error plus as much information about your system (OS, python version, canopy version etc).

Hope this helps!

Best,
Zack

Thanks for your kind & warm reply, Zachary!

Windows 11 Pro 10.0.22631 build 22631, machine is an decent Intel i5/9600KF, 48Gb RAM, loads of HD, 3080TI.
Python 3.11.8, Conda installed, no admin folder permissions issues but I can check again if there’s something specific regarding Canopy, got latest Canopy from GitHub repo (0.9.0).
All packages installed and confirmed by PIP, .env and .env variables set and checked using both PyCharm and CMD directly.
Country is Brazil, IP block 177.x.x.x
Basic / free plan here on Pinecone so far. I have an account on AWS but (a) it was not logged on at the time and (b() my server there is US_East_1.

Read everything more than twice, watched the demo video, read the documents, sent them to OpenAI Assistant in case I missed something … nothing found.

All tries to run “canopy new” result in the same error.

I’ll send all that to the repo, as suggested.

Then, as I hadn’t mentioned it in the previous message, and just to be sure I’m not giving you an incomplete answer, I’ll get one of two errors:

  1. NOT specifying an index name

(canopy-env) C:\Users\charl\CanopyTest>canopy new
Canopy is going to create a new index named canopy–/ with the following initialization parameters:
{}

Do you want to continue? [y/N]: y
Error: Failed to create a new index. Reason:
Failed to create index canopy–/ due to error: {“error”:{“code”:“INVALID_ARGUMENT”,“message”:“Name must consist of lower case alphanumeric characters or ‘-’”},“status”:400}

  1. by SPECIFYING an index name

Canopy is going to create a new index named canopy–test with the following initialization parameters:
{}

Do you want to continue? [y/N]: y
Error: Failed to create a new index. Reason:
Failed to create index canopy–test due to error: {“error”:{“code”:“INVALID_ARGUMENT”,“message”:“Bad request: Your free plan does not support indexes in the us-west-2 region of aws. To create indexes in this region, upgrade your plan.”},“status”:400}


I’ve carefully read the return from CMD “SET”.
PINECONE_API_KEY is set
OPENAI_API_KEY is set
Conda variables all point to the right env
(I can paste the rest if you want me to, but I’ll proceed to GitHub as you suggested!)

In the meantime, I’m giving up on Canopy until someone might solve this as it’s already been very expensive. It’s probably something incredibly simple AND awkward, as web searches didn’t find much about this.

Tks again!

As another idea to explore, do you know where I can find the specification for CANOPY_CONFILE? Seems to be missing from documentation, website, everything.

I’m seeing this as a reply for web queries:

default_project: my_project
api_key: YOUR_API_KEY
indexes:
  - name: my_index
    type: pinecone
    config:
      dimension: 1536
      metric: cosine

but without a clue as to how that index can be created outside of Canopy.

BTW, creating the index inside Pinecone works just fine, but then I haven’t found a clear beginner’s guide on how to use it!

Tks again!