Can't connect to existing index

I just created a new index(free tier) and everything worked fine(upsert dozens).
Now when I tried to reconnect to the index I get
ProtocolError: ('Connection aborted.', ConnectionResetError(54, 'Connection reset by peer')) The above exception was the direct cause of the following exception: PineconeProtocolError Traceback (most recent call last) Cell In[26], [line 1](vscode-notebook-cell:?execution_count=26&line=1) ----> [1](vscode-notebook-cell:?execution_count=26&line=1) index.upsert(vectors=[data[0]]) [2](vscode-notebook-cell:?execution_count=26&line=2) # data[0] File [~/sam-api/.venv/lib/python3.9/site-packages/pinecone/core/utils/](, in validate_and_convert_errors.<locals>.inner_func(*args, **kwargs) [23]( raise [24]( except ProtocolError as e: ---> [25]( raise PineconeProtocolError(f'Failed to connect; did you specify the correct index name?') from e PineconeProtocolError: Failed to connect; did you specify the correct index name?

I also deleted the index and created a new one with a different name and I got the same error(now the index is empty).
Any suggestion?

Code would help to see here as its an easy fix - guaranteed.

Likely issues:

  • Index is not in “ready” state
  • Index name is incorrect for the given environment URL
  • API key is missing or wrong

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.