Slow creating index in us-west4-gcp-free

I have been waiting at least 2 hours for my index to be created. It is stuck in “Initializing”. I am deploying in the us-west4-gcp-free region.

Is it possible for the index to get stuck? Should I delete it and recreate it, or should I keep waiting?

The initialization ultimately failed, with no clear error message. Trying again :crossed_fingers:

Initialization failed again:

Not sure what to do here, the UI is not very helpful

1 Like

I solved the issue by changing the name of the index.

It seems that when you delete an index, and try to create a new one with the same name, the creation fails.

I hope this helps anyone else encountering the issue

Devs, plz fix

1 Like

Thank you for posting this. I’m currently facing the same issue. Waiting for the initialization to ultimately fail.

I did delete an index and created a new one with the same name the other day and everything was working perfectly.

Now i deleted it again and created a new one with the same name shortly after and now i’m stuck in the initializtion phase.

1 Like

I deleted an index and tried creating a new one using a different name, and it got stuck for 1-2 hours then failed. I then tried several more times (with the same name) and got the same result. It’s very frustrating.

On the next attempt (after waiting several hours for the latest failure), I’ll try a different name, but that didn’t stop the initial attempt from failing.

Think there’s a serious problem here that the Pinecone folks will need to resolve.

1 Like

They should care, but this has been a known issue for a long time so…

1 Like

Sorry to hear my fix didn’t work for you. I hope some devs get on here soon with some kind of response

Actually, I got a private response from Pinecone. What’s happening is that they’re rationing access to new trial accounts, slowing set-up until they have infrastructure available. However, the way they’ve implemented the rationing, it seems to affect all index-creation on trial accounts — so if you delete an index and then go to recreate it, you end up at the back of the new-account queue, waiting for new infrastructure.

The best thing to do is just wait wait wait retry retry retry until you score a new index, and then never delete it (rather, empty and re-populate it as needed).


I have new trial account and it takes about 3 minutes to create index with the same name as previous one after deleting it. The problem is that you need to poll the index state until it becomes Ready. What should have been done is some kind of event you can receive that notifies that index is ready instead of polling…