# Max retries exceeded with url: /vectors/upsert - Error on Pinecone side or my side?

**URL:** <https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535>\
**Category:** Support\
**Tags:** vector-database\
**Created:** [April 25, 2023, 8:46pm UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535 "2023-04-25T20:46:43Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![frankie](https://sea2.discourse-cdn.com/flex020/user_avatar/community.pinecone.io/frankie/32/358_2.png) [@frankie](https://community.pinecone.io/u/frankie)\
**Post date:** [April 25, 2023, 8:46pm UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535/1 "2023-04-25T20:46:43Z")

</div>

How can I figure out whether this is due to Pinecone, or my code?  
Here’s the full error:  
`MaxRetryError: HTTPSConnectionPool(host='langchain-ea0dc1e.svc.asia-northeast1-gcp.pinecone.io', port=443): Max retries exceeded with url: /vectors/upsert (Caused by SSLError(SSLEOFError(8, 'EOF occurred in violation of protocol (_ssl.c:2396)')))`

Occurs during attempt to upsert vectors.

---

<div class="post-metadata">

**Author:** ![Cory\_Pinecone](https://sea2.discourse-cdn.com/flex020/user_avatar/community.pinecone.io/cory_pinecone/32/1712_2.png) [@Cory\_Pinecone](https://community.pinecone.io/u/Cory_Pinecone)\
**Post date:** [April 25, 2023, 9:15pm UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535/2 "2023-04-25T21:15:09Z")

</div>

Hi @frankie. We’re currently experiencing an incident in the `asia-northeast1-gcp` region affecting API keys. The error you’re seeing is due to that incident.

To keep up to date on the status of this incident, please subscribe to [our status page](https://status.pinecone.io/).

---

<div class="post-metadata">

**Author:** ![frankie](https://sea2.discourse-cdn.com/flex020/user_avatar/community.pinecone.io/frankie/32/358_2.png) [@frankie](https://community.pinecone.io/u/frankie)\
**Post date:** [April 25, 2023, 10:23pm UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535/3 "2023-04-25T22:23:35Z")

</div>

I’m not able to create a new key that is not in the asia region. is there a way?

---

<div class="post-metadata">

**Author:** ![rmaniyembath](https://sea2.discourse-cdn.com/flex020/user_avatar/community.pinecone.io/rmaniyembath/32/409_2.png) [@rmaniyembath](https://community.pinecone.io/u/rmaniyembath)\
**Post date:** [April 30, 2023, 5:08am UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535/4 "2023-04-30T05:08:31Z")

</div>

Is this Issue Resolved , I am getting the same error for the past 2 hours.

MaxRetryError: HTTPSConnectionPool(host=‘[xxxxxxxx.svc.asia-northeast1-gcp.pinecone.io](http://xxxxxxxx.svc.asia-northeast1-gcp.pinecone.io)’, port=443): Max retries exceeded with url: /vectors/upsert (Caused by SSLError(SSLEOFError(8, ‘EOF occurred in violation of protocol (\_ssl.c:2423)’)))

---

<div class="post-metadata">

**Author:** ![frankie](https://sea2.discourse-cdn.com/flex020/user_avatar/community.pinecone.io/frankie/32/358_2.png) [@frankie](https://community.pinecone.io/u/frankie)\
**Post date:** [April 30, 2023, 4:30pm UTC](https://community.pinecone.io/t/max-retries-exceeded-with-url-vectors-upsert-error-on-pinecone-side-or-my-side/1535/5 "2023-04-30T16:30:09Z")

</div>

Error went away when the servers were fixed. It may be due to another problem with the servers. Check the server status page to see if it’s up or down.
