Getting error when query vector by namespace

I got this error “[TypeError: Cannot read properties of undefined (reading ‘text’)]” when query data by using namespace. Namespace and embbedings variable is correct value in this case. Did you experience with this?
This is my function query:

 const queryResult = await namespace.query({
      topK: 5,
      vector: embeddings,
      includeMetadata: true,

Im getting the same error using

"@pinecone-database/pinecone": "^1.0.1",

Hi, all! Audrey from Pinecone here. We are aware of this issue and are working on a fix for it as we speak. I will update here as soon as it’s pushed to prod!

1 Like

getting same error …waiting for it to be fixed since 2 days

This issue is not fixed till now…
I think I need to move to another vector db

We are still working on this. We apologize it is taking a while, but appreciate you bearing with us!

Hi all, quick question: are you using nextJS to interact with Pinecone?

If you could share any environment dependencies you all are using on this thread, we would be very grateful!

@appydam , @vikrant , @maorrocky , and @manhtv.peko

1 Like

Hi, thanks for your reply. But I just updated latest version of Pinecone and i think it completely fixed for me the error above.

1 Like

Hell yeah, that’s so great!!

@appydam , @vikrant , @maorrocky lmk if upgrading doesn’t work for you!